State minimization in MuSig2 signing sessions

State minimization in MuSig2 signing sessions

Original Postby salvatoshi

Posted on: March 7, 2024 12:52 UTC

The message highlights a decision to rename a certain identifier to psbt_session_id for the sake of clarity.

The sender acknowledges the feedback received on a section titled 'Generalization' within their original post, admitting it was added for completeness despite not being the primary focus or a significant concern. This section's inclusion was based on its practical utility rather than its relevance to the main topic. Furthermore, gratitude is expressed towards the feedback provided, which has been deemed beneficial. The sender also mentions a limitation encountered with editing the original post due to time constraints but commits to incorporating the suggested changes regarding naming conventions in future code development.